Heroku में जेआरई स्थापित करें

I got this error in running heroku run rake sunspot:solr:run

rake aborted!
You need a Java Runtime Environment to run the Solr server

क्या मैं एक तरीका है जिसे मैं जरूरी में जरूरी स्थापित कर सकता हूं?

0
जोड़ा संपादित
विचारों: 1

1 उत्तर

आप Heroku पर जेआरई स्थापित नहीं कर सकते हैं, और इस प्रकार आप एक हेरोकू कार्यकर्ता से सोलर नहीं चला सकते हैं।

यदि आप हेरोोकू में सोलर चाहते हैं, तो आपको Websolr एडन का उपयोग करना होगा, या एक ईसी 2 शुरू करना होगा सर्वर और वहां से सोलर की अपनी प्रति चलाएं।

0
जोड़ा
सुनकर दुख हुआ। हालांकि मैंने सोलर के लिए अपना खुद का सर्वर चलाने की कोशिश की, यह काम नहीं किया। शायद reindexing मुद्दों की वजह से।
जोड़ा लेखक Jude Calimbas, स्रोत
क्या हेरोकू अब JVM- आधारित भाषाओं की पेशकश नहीं करता है?
जोड़ा लेखक echristopherson, स्रोत