फोनगैप 2.5 के लिए नवीनतम संस्करण 3.1 में प्लगइन को अपग्रेड कैसे करें? और फोनगैप में अतिरिक्त प्लगइन जोड़ने के लिए प्रवाह क्या है

$('#sendSms').click(function(e){
    alert("sendSms on progress");//After this alert I got continuuous errors,I can't found the reason for it
var smsInboxPlugin = cordova.require('cordova/plugin/smsinboxplugin');
smsInboxPlugin.isSupported ((function(supported) {
    if(supported) {
      alert("SMS supported !");
      window.location.href="sms:phonenum?body=haiii";
    } else
      alert("SMS not supported");
  }), function() {
    alert("Error while checking the SMS support");
  });

प्लगइन के लिए एमए लिंक यहां दिया गया है जिसका उपयोग मैंने Pyo25/Phonegap-SMS- स्वागत-प्लगइन मैंने सभी जावा क्लास त्रुटि को सही किया है लेकिन समस्या बनी हुई है ... मुझे हमेशा त्रुटि मिली Uncaught मॉड्यूल कॉर्डोवा/प्लगइन/smsinboxplugin नहीं मिला: 56

2
जोड़ा संपादित
विचारों: 1
कृपया अपने नमूना बग कोड से अपना मोबाइल नंबर हटा दें ..
जोड़ा लेखक Bebin T.N, स्रोत

1 उत्तर

त्रुटि का मतलब है कि कॉर्डोवा आवश्यक कार्यों को खोजने में सक्षम नहीं है।

किसी भी प्लगइन का उपयोग करने के लिए, आपको अपने किसी भी फ़ंक्शन का उपयोग करने से पहले .js फ़ाइल को शामिल करना चाहिए और HTML फ़ाइल में cordova.js फ़ाइल को शामिल करने के बाद।

इसके अलावा आपने अपनी परियोजना में प्लगइन कैसे जोड़ा? सीएलआई उपकरण के माध्यम से एक नई प्लगइन जोड़ने की हमेशा सिफारिश की जाती है।

0
जोड़ा
यह 2.5 संस्करण के लिए एक प्लगइन है इसलिए मैंने जावा फाइलों को src part और JS फ़ाइलों में पृष्ठ में ही जोड़ा। लेकिन यह ठीक से काम नहीं करेगा
जोड़ा लेखक Anand Tagore, स्रोत