Geoip2 जीपीजी गुप्त कुंजी के लिए पूछता है

मैं geoip2 स्थानीय रूप से उपयोग करने की कोशिश कर रहा हूँ। मेरे पास कोई जीजीपी स्थापित नहीं है। मुझे "gpg: कोई डिफ़ॉल्ट गुप्त कुंजी नहीं मिलती: अनुपयोगी गुप्त कुंजी"। क्या मुझे पहले जीजीपी स्थापित करना चाहिए? और क्या गुम हो सकता है?

0
क्या आपके पास आपकी मशीन में एसएसएल स्थापित है? मुझे विश्वास है कि एपीआई आवश्यक क्रिप्टोग्राफिक लाइब्रेरी पहले स्थापित है।
जोड़ा लेखक Michael C., स्रोत
एपीआई geoip2-0.7.0.jar है, maxminddb-0.2.0.jar सुनिश्चित नहीं है कि इसे एसएसएल की आवश्यकता है क्योंकि यह स्पष्ट रूप से जीपीजी (पीजीपी 8- के लिए नहीं) के लिए पूछता है। मुझे लगता है कि मेरे पास मेरी मशीन पर कुछ एसएसएल है (विन 7) क्योंकि यह https को पढ़ने में सक्षम है। जीपीजी स्थापित करने की कोशिश करेंगे ...
जोड़ा लेखक Dima, स्रोत
GeoIP2 सिर्फ एक डेटाबेस है। क्या आप एपीआई में से एक स्थापित करने की कोशिश कर रहे हैं? यदि हां, तो कौन सा?
जोड़ा लेखक Greg Oschwald, स्रोत